Updates to StatusCast's privacy policy

Informational
March 20, 2:00pm EST

Updates to StatusCast's privacy policy

Status: closed
Date: March 20, 2:00pm EST
Affected Components:
*.status.page status pages CNAME status pages *.statuscast.com status pages Admin application Notification services Status pages Cloud Providers
Update

March 20, 2:00pm EST

March 20, 2:00pm EST

 

StatusCast is deeply committed to the protection and responsible use of data; we’ve made a few updates to our privacy policy to help you better understand how we collect and use information. We hope these changes more clearly articulate our responsibility to you.

 

By continuing to use our services on or after March 25, 2020, you indicate your agreement with each of the updated and new terms and policies that are effective as of that date. If you have any questions or concerns, please email support@statuscast.com or reply to this email.