Post Daylight Savings Incident Timing

Informational
March 19, 12:05pm EST

Post Daylight Savings Incident Timing

Status: closed
Date: March 19, 12:05pm EST
Affected Components:
Admin application
Update

March 19, 12:05pm EST

March 19, 12:05pm EST

StatusCast’s engineers were alerted that some users were experiencing time conversion issues after daylight savings had become active, resulting in some posts being scheduled 1 hour off from the intended date/time. After a thorough investigation it was determined that the local browser cache for affected users was not being invalidated as expected and as a result the time submissions were being evaluated with a different time offset for ‘Standard’ time.  After discovering this cause our engineers pushed out a cache invalidation to force all users connecting to the admin portal to completely reload the appropriate bundles. Most users were unaffected by this issue as it was localized to an individual’s browser but we are re-evaluating how caching of certain libraries work in the administrative portal to ensure this does not happen again in the future.

Resolved

March 19, 12:05pm EST

March 19, 12:05pm EST

Resolved.