Unable to connect to status pages

Disruption
April 01, 6:40pm EST

Unable to connect to status pages

Status: closed
Start: April 01, 6:27pm EST
End: April 01, 6:40pm EST
Duration: 12 minutes
Affected Components:
*.status.page status pages CNAME status pages *.statuscast.com status pages Admin application Status pages
Update

April 01, 6:27pm EST

April 01, 6:27pm EST

StatusCast’s engineers were alerted that our hosting provider; Azure, starting at approximately 21:30 UTC on 01 Apr 2021 started experiencing global issues with certain downstream services that StatusCast utilize.  As a result, some users were unable to connect directly to their status page or administrative portal.   Our engineers implemented fail-over procedures and at this time the application is available for all users. We will continue to monitor the situation with Azure, for more information related to Azure specifically please visit their status page here. 

Resolved

April 01, 6:40pm EST

April 01, 6:40pm EST

Microsoft remediated their DNS issues fairly quickly and StatusCast customers had minimal impact.