Latency on v3 API Mail Sends

Performance
July 13, 4:09pm EST

Latency on v3 API Mail Sends

Status: closed
Start: July 13, 11:34am EST
End: July 13, 4:09pm EST
Duration: 4 hours 35 minutes
Affected Components:
Cloud Providers SendGrid
Update

July 13, 11:34am EST

July 13, 11:34am EST

Starting around 8:15am PDT on Tuesday, July 13th our engineers discovered latency with v3 Mail Sends. The issue has been identified and are currently monitoring. We will provide updates in the next hour or sooner as they become available.

Update

July 13, 11:39am EST

July 13, 11:39am EST

We are continuing to monitor for any further issues.

Update

July 13, 12:33pm EST

July 13, 12:33pm EST

We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.

Update

July 13, 1:26pm EST

July 13, 1:26pm EST

Engineering is continuing to monitor the issue and believe customer's may continue to see issues with higher than normal latency with V3 Mail Sends and Marketing Campaigns. We will provide updates in the next hour or sooner as they become available.

Update

July 13, 2:40pm EST

July 13, 2:40pm EST

Engineering has implemented a fix and has mitigated the issue. We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.

Update

July 13, 3:41pm EST

July 13, 3:41pm EST

Engineering has implemented a fix and has mitigated the issue. We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.

Resolved

July 13, 4:09pm EST

July 13, 4:09pm EST

Our engineers have monitored the fix and confirmed the issue with latency has been resolved for v3 Mail Sends and Marketing Campaigns. All services are now operating normally at this time.