Delivery delays for transactional messages in EU

Performance
July 13, 1:00pm EST

Delivery delays for transactional messages in EU

Status: closed
Start: July 13, 11:48am EST
End: July 13, 1:00pm EST
Duration: 1 hour 12 minutes
Affected Components:
Cloud Providers Mailgun
Update

July 13, 11:48am EST

July 13, 11:48am EST

We are currently investigating an issue with delivery delays for transactional messages in the EU region.

Resolved

July 13, 1:00pm EST

July 13, 1:00pm EST

This incident has been resolved.