Delivery Delays for the US Region

Performance
September 10, 2:17pm EST

Delivery Delays for the US Region

Status: closed
Start: September 10, 1:46pm EST
End: September 10, 2:17pm EST
Duration: 30 minutes
Affected Components:
Cloud Providers Mailgun
Update

September 10, 1:46pm EST

September 10, 1:46pm EST

We are currently investigating this issue.

Update

September 10, 1:53pm EST

September 10, 1:53pm EST

The issue has been identified and a fix is being implemented.

Resolved

September 10, 2:17pm EST

September 10, 2:17pm EST

This incident has been resolved.