SSL connection issues

Informational
October 01, 12:35am EST

SSL connection issues

Status: closed
Date: September 30, 12:56pm EST
Affected Components:
Cloud Providers Mailgun
Update

September 30, 12:56pm EST

September 30, 12:56pm EST

We're currently investigating reports where some SSL connections are failing for webhooks and routes.

Update

September 30, 1:09pm EST

September 30, 1:09pm EST

We are continuing to investigate this issue.

Update

September 30, 1:24pm EST

September 30, 1:24pm EST

We've identified an issue where TLS connections are failing for webhooks and route notifications. This issue does not affect all endpoints and is limited to endpoints using certificates from certain providers. We're continuing to work towards a resolution.

Update

September 30, 2:08pm EST

September 30, 2:08pm EST

We are continuing to work on a fix for this issue.

Update

September 30, 3:02pm EST

September 30, 3:02pm EST

We are continuing to work on a fix for this issue.

Update

September 30, 4:12pm EST

September 30, 4:12pm EST

We are continuing to work on a fix for this issue.

Update

September 30, 7:27pm EST

September 30, 7:27pm EST

A fix has been implemented, we are monitoring the results, and the system is currently working through the backlog.

Update

September 30, 9:37pm EST

September 30, 9:37pm EST

We are continuing to monitor the system as it works through the backlog.

Resolved

October 01, 12:35am EST

October 01, 12:35am EST

This incident has been resolved.