Delivery delays for the EU region

Performance
September 30, 8:51pm EST

Delivery delays for the EU region

Status: closed
Start: September 30, 8:34pm EST
End: September 30, 8:51pm EST
Duration: 17 minutes
Affected Components:
Cloud Providers Mailgun
Update

September 30, 8:34pm EST

September 30, 8:34pm EST

We are currently investigating this issue.

Resolved

September 30, 8:51pm EST

September 30, 8:51pm EST

This incident has been resolved.