Delivery delays for the EU region

Performance
October 07, 3:52am EST

Delivery delays for the EU region

Status: closed
Start: October 07, 3:14am EST
End: October 07, 3:52am EST
Duration: 38 minutes
Affected Components:
Cloud Providers Mailgun
Update

October 07, 3:14am EST

October 07, 3:14am EST

We are currently investigating this issue.

Update

October 07, 3:50am EST

October 07, 3:50am EST

A fix has been implemented and we are monitoring the results.

Resolved

October 07, 3:52am EST

October 07, 3:52am EST

This incident has been resolved.