Deliver delays for the US region

Performance
October 07, 12:38pm EST

Deliver delays for the US region

Status: closed
Start: October 07, 11:29am EST
End: October 07, 12:38pm EST
Duration: 1 hour 8 minutes
Affected Components:
Cloud Providers Mailgun
Update

October 07, 11:29am EST

October 07, 11:29am EST

We are currently investigating this issue.

Update

October 07, 12:03pm EST

October 07, 12:03pm EST

The issue has been identified and a fix is being implemented.

Update

October 07, 12:16pm EST

October 07, 12:16pm EST

A fix has been implemented, and we are currently monitoring the results and working through the backlog.

Resolved

October 07, 12:38pm EST

October 07, 12:38pm EST

This incident has been resolved.