Delivery delays for the EU region

Performance
October 08, 8:03am EST

Delivery delays for the EU region

Status: closed
Start: October 08, 7:29am EST
End: October 08, 8:03am EST
Duration: 33 minutes
Affected Components:
Cloud Providers Mailgun
Update

October 08, 7:29am EST

October 08, 7:29am EST

We are currently investigating this issue.

Update

October 08, 7:54am EST

October 08, 7:54am EST

A fix has been implemented and we are monitoring the results.

Resolved

October 08, 8:03am EST

October 08, 8:03am EST

This incident has been resolved.