EU Sending Delays

Performance
November 09, 4:38am EST

EU Sending Delays

Status: closed
Start: November 09, 3:11am EST
End: November 09, 4:38am EST
Duration: 1 hour 26 minutes
Affected Components:
Cloud Providers Mailgun
Update

November 09, 3:11am EST

November 09, 3:11am EST

Mailgun EU is experiencing sending delays

Update

November 09, 3:42am EST

November 09, 3:42am EST

Sending queue is starting to reduce

Update

November 09, 4:13am EST

November 09, 4:13am EST

A fix has been implemented and we are monitoring the results.

Resolved

November 09, 4:38am EST

November 09, 4:38am EST

This incident has been resolved.