Sending delays in the US region

Informational
November 12, 10:02am EST

Sending delays in the US region

Status: closed
Date: November 12, 9:49am EST
Affected Components:
Cloud Providers Mailgun
Update

November 12, 9:49am EST

November 12, 9:49am EST

We are currently investigating this issue.

Update

November 12, 9:55am EST

November 12, 9:55am EST

We are continuing to investigate this issue.

Update

November 12, 9:58am EST

November 12, 9:58am EST

A fix has been implemented and we are monitoring the results.

Resolved

November 12, 10:02am EST

November 12, 10:02am EST

This incident has been resolved.