Email delivery delays for the EU region

Performance
November 22, 9:47am EST

Email delivery delays for the EU region

Status: closed
Start: November 22, 8:21am EST
End: November 22, 9:47am EST
Duration: 1 hour 25 minutes
Affected Components:
Cloud Providers Mailgun
Update

November 22, 8:21am EST

November 22, 8:21am EST

We are currently investigating this issue.

Update

November 22, 9:23am EST

November 22, 9:23am EST

A fix has been implemented and we are monitoring the results.

Resolved

November 22, 9:47am EST

November 22, 9:47am EST

This incident has been resolved.