SMS Delivery Delays from Toll-Free Numbers to Telus and Roger Canada

Informational
November 25, 10:15pm EST

SMS Delivery Delays from Toll-Free Numbers to Telus and Roger Canada

Status: closed
Date: November 25, 6:57pm EST
Affected Components:
Cloud Providers Twilio
Update

November 25, 6:57pm EST

November 25, 6:57pm EST

ur monitoring systems have detected a potential issue with SMS delivery delays from Toll-Free Canada numbers to Telus and Roger. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Update

November 25, 7:25pm EST

November 25, 7:25pm EST

We are experiencing SMS delivery delays when sending messages to Toll-Free Numbers to Telus and Roger Canada. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Update

November 25, 8:25pm EST

November 25, 8:25pm EST

We are still experiencing SMS delivery delays when sending messages to Toll-Free Numbers to Telus and Roger Canada. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Update

November 25, 10:15pm EST

November 25, 10:15pm EST

We are observing recovery in SMS delivery delays when sending messages from Toll-Free Numbers to Telus and Rogers Canada. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.