SMS and MMS Latency for a Subset of Twilio Customers

Performance
December 01, 1:38pm EST

SMS and MMS Latency for a Subset of Twilio Customers

Status: closed
Start: December 01, 12:35pm EST
End: December 01, 1:38pm EST
Duration: 1 hour 2 minutes
Affected Components:
Cloud Providers Twilio
Update

December 01, 12:35pm EST

December 01, 12:35pm EST

Our monitoring systems have detected a potential issue with high latency for MMS sending. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Update

December 01, 12:55pm EST

December 01, 12:55pm EST

We are experiencing elevated SMS and MMS latency when sending to US and Canadian networks for a small subset of Twilio customers. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.

Update

December 01, 1:10pm EST

December 01, 1:10pm EST

We are observing recovery with SMS and MMS latency when sending to US and Canadian networks. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 mins or as soon as more information becomes available.

Resolved

December 01, 1:38pm EST

December 01, 1:38pm EST

We are no longer experiencing latency when sending MMS and SMS. This incident has been resolved.