Inbound Call Failures to a Subset of Twilio Phone Numbers

Informational
March 12, 10:26pm EST

Inbound Call Failures to a Subset of Twilio Phone Numbers

Status: closed
Date: March 12, 7:51pm EST
Affected Components:
Cloud Providers Twilio
Update

March 12, 7:51pm EST

March 12, 7:51pm EST

Our monitoring systems have detected a potential issue impacting inbound calls to a subset of Twilio phone numbers. Our engineering team has been alerted and is actively investigating. We will provide another update within the next 30 minutes or as soon as more information becomes available.

Update

March 12, 8:09pm EST

March 12, 8:09pm EST

We are investigating a potential issue impacting inbound calls to a subset of Twilio phone numbers. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Update

March 12, 8:38pm EST

March 12, 8:38pm EST

We are continuing to investigate an issue impacting inbound calls to a subset of Twilio phone numbers using Twimlets. We expect to provide another update in 60 minutes or as soon as more information becomes available.

Update

March 12, 9:30pm EST

March 12, 9:30pm EST

We are continuing to investigate an issue impacting inbound calls to a subset of Twilio phone numbers using Twimlets. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Update

March 12, 9:52pm EST

March 12, 9:52pm EST

We have started seeing recovery for the Inbound calls and Flex. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Resolved

March 12, 10:26pm EST

March 12, 10:26pm EST

The issue affecting inbound calls and Flex has been resolved, and the service is functioning normally at this time.