On Call Engineers are Investigating

Informational
March 15, 5:30pm EST

On Call Engineers are Investigating

Status: closed
Date: March 15, 5:15pm EST
Affected Components:
Cloud Providers Twilio
Update

March 15, 5:15pm EST

March 15, 5:15pm EST

Our monitoring systems have detected a potential degradation with multiple products for users in Australia due to database delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Resolved

March 15, 5:30pm EST

March 15, 5:30pm EST

We have fully investigated the issue of degraded product performance for users in Australia and it was determined that this impact lasted from approximately 13:52 PST to 14:10 PST. All systems are operational and this incident is now resolved.