On Call Engineers are Investigating MMS Delivery Receipt Delays to US Multiple Networks Via a Subset of Shortcodes

Informational
March 19, 1:11am EDT

On Call Engineers are Investigating MMS Delivery Receipt Delays to US Multiple Networks Via a Subset of Shortcodes

Status: closed
Date: March 18, 7:45pm EDT
Affected Components:
Cloud Providers Twilio
Update

March 18, 7:45pm EDT

March 18, 7:45pm EDT

Our monitoring systems have detected a potential issue with MMS delivery receipt delays to multiple networks in the US via a subset of shortcodes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Update

March 18, 8:11pm EDT

March 18, 8:11pm EDT

We are experiencing delays in receiving message delivery reports when sending MMS to multiple US networks via a subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.

Update

March 18, 9:11pm EDT

March 18, 9:11pm EDT

We are experiencing delays in receiving message delivery reports when sending MMS to multiple US networks via a subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.

Update

March 18, 11:11pm EDT

March 18, 11:11pm EDT

We are observing recovery in delays in receiving message delivery reports when sending MMS to multiple US networks via a subset of Twilio Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.