SMS Delivery Failures to Singapore

Performance
March 23, 12:31am EST

SMS Delivery Failures to Singapore

Status: closed
Start: March 22, 10:33pm EST
End: March 23, 12:31am EST
Duration: 1 hour 57 minutes
Affected Components:
Cloud Providers Twilio
Update

March 22, 10:33pm EST

March 22, 10:33pm EST

We've become aware of a potential issue with SMS Delivery Failures to Singapore. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Update

March 22, 11:03pm EST

March 22, 11:03pm EST

We are investigating SMS filtering issue with messages sending to Singapore for a subset of customers. We expect to provide another update in 1 hour or as soon as more information becomes available.

Update

March 23, 12:01am EST

March 23, 12:01am EST

Our engineers have implemented a fix to resolve the SMS filtering issue with messages sending to Singapore for a subset of customers. We are observing successful SMS delivery to Singapore. We will continue to monitor to ensure full service recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Resolved

March 23, 12:31am EST

March 23, 12:31am EST

We are no longer experiencing SMS filtering issue when sending messages to Singapore. This incident has been resolved.