SMS Delivery Delay to Telenor Network In Pakistan

Performance
March 23, 5:54pm EST

SMS Delivery Delay to Telenor Network In Pakistan

Status: closed
Start: March 23, 1:23pm EST
End: March 23, 5:54pm EST
Duration: 4 hours 30 minutes
Affected Components:
Cloud Providers Twilio
Update

March 23, 1:23pm EST

March 23, 1:23pm EST

We are experiencing SMS delivery delays when sending messages to Telenor Network In Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Update

March 23, 2:23pm EST

March 23, 2:23pm EST

We are experiencing SMS delivery delays when sending messages to Telenor Network In Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Update

March 23, 2:29pm EST

March 23, 2:29pm EST

We are experiencing SMS delivery delays when sending messages to Telenor Network In Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Update

March 23, 3:53pm EST

March 23, 3:53pm EST

We are observing recovery in the issue causing SMS delivery delays when sending messages to the Telenor Network In Pakistan. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

March 23, 5:54pm EST

March 23, 5:54pm EST

We are no longer experiencing SMS delivery delays when sending messages to the Telenor network in Pakistan. This incident has been resolved.