SMS Delivery Delays and Failures To SETAR and Digicel in Aruba

Performance
March 29, 11:15pm EST

SMS Delivery Delays and Failures To SETAR and Digicel in Aruba

Status: closed
Start: March 29, 3:26pm EST
End: March 29, 11:15pm EST
Duration: 7 hours 49 minutes
Affected Components:
Cloud Providers Twilio
Update

March 29, 3:26pm EST

March 29, 3:26pm EST

Our monitoring systems have detected a potential issue with SMS Delivery Delays and Failures to SETAR and Digicel in Aruba . Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Update

March 29, 4:36pm EST

March 29, 4:36pm EST

We are continuing to experience SMS Delivery Delays and Failures to SETAR and Digicel in Aruba. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour, or as soon as more information becomes available.

Update

March 29, 7:05pm EST

March 29, 7:05pm EST

We are observing recovery in SMS Delivery Delays and Failures to SETAR and Digicel in Aruba. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours, or as soon as more information becomes available.

Update

March 29, 8:59pm EST

March 29, 8:59pm EST

We are observing recovery in SMS Delivery Delays and Failures to SETAR and Digicel in Aruba. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours, or as soon as more information becomes available.

Resolved

March 29, 11:15pm EST

March 29, 11:15pm EST

We are no longer experiencing SMS delivery delays and failures when sending messages to SETAR and Digicel in Aruba. This incident has been resolved.