Sending delays for some batches and mailing lists in US

Performance
April 06, 7:50am EST

Sending delays for some batches and mailing lists in US

Status: closed
Start: April 06, 7:35am EST
End: April 06, 7:50am EST
Duration: 14 minutes
Affected Components:
Cloud Providers Mailgun
Update

April 06, 7:35am EST

April 06, 7:35am EST

The issue has been identified and a fix is being implemented.

Update

April 06, 7:38am EST

April 06, 7:38am EST

A fix has been implemented and we are monitoring the results.

Resolved

April 06, 7:50am EST

April 06, 7:50am EST

This incident has been resolved.