Certificate errors for links in Google Chrome

Informational
May 02, 10:36pm EST

Certificate errors for links in Google Chrome

Status: closed
Date: May 02, 8:22pm EST
Affected Components:
Cloud Providers SendGrid
Update

May 02, 8:22pm EST

May 02, 8:22pm EST

Starting around 5:10 PT on May 2, 2022 our engineers began investigating an issue involving the validity of link certificates for SendGrid links. Customer may see errors when clicking on links when using Google Chrome. This does not impact mail send. As a workaround, please try opening the link in a different web browser. We will provide another update in 1 hour or as soon as more information becomes available.

Update

May 02, 9:05pm EST

May 02, 9:05pm EST

Our team identified the root cause of the certificate errors when attempting to resolve SendGrid links with Google Chrome browser. At this time, we are working towards implementing a solution to allow links to properly resolve. Another update will be provided in one hour or when a substantial update is available.

Update

May 02, 10:15pm EST

May 02, 10:15pm EST

We are still determining the solution for resolving the link certificate errors shown with Google Chrome on some versions. Updates will be given within the next two hours or as soon as more significant updates are available.