Status page and admin portal latency

Incident
July 19, 6:48pm EDT

Status page and admin portal latency

Status: closed
Start: July 19, 4:39pm EDT
End: July 19, 6:48pm EDT
Duration: 2 hours 8 minutes
Affected Components:
Status pages Admin application CNAME status pages *.status.page status pages
Update

July 19, 4:39pm EDT

July 19, 4:39pm EDT

StatusCast's engineers have been alerted that some users are experiencing latency when attempting to access their status page as well as their administrative portal. At this time this latency does not appear to be impacting all users.

Engineers are working to resolve this now and we will post an update shortly when more information is available. 



Resolved

July 19, 6:48pm EDT

July 19, 6:48pm EDT

At this time all services should be operating as expected, if you continue to experience any further issues please reach out to StatusCast support at support@statuscast.com.


We will follow up with additional information related to the root cause of this latency at a later time.